Audio Video Revolution Forum  

Go Back   Audio Video Revolution Forum > Audio-Video Electronics > Receivers

Receivers Ask your questions on AV receivers ranging from HDMI connectivity to calibration to setup to power ratings and beyond.

Reply
 
Thread Tools Display Modes
Old 02-07-2010   #1
New Member
 
Join Date: Feb 2010
Location: Las Vegas
Posts: 2
Question 7.1 surround not working

I have a Sony str-dg820 receiver hooked up via hdmi to my Sony bd player and also my Samsung plasma. When I put in a blu ray with 7.1, for some reason it does not show the surround speakers (lit up on the display) hooked up on the display.When the movie starts it does show 3/4-1 on the display. I did calibrate the speakers, which are polk audio, via the microphone, and all the speakers do work well, just not sure if I am missing something. Thanks
liljoe1969 is offline   Reply With Quote
Old 02-07-2010   #2
Administrator
 
rbinck's Avatar
 
Join Date: Mar 2009
Location: Katy, TX
Posts: 768
Default Re: 7.1 surround not working

Have you checked the audio settings on the BD player?
rbinck is offline   Reply With Quote
Old 02-07-2010   #3
New Member
 
Join Date: Feb 2010
Location: Las Vegas
Posts: 2
Default Re: 7.1 surround not working

I have output set up to hdmi, the audio hdmi set to auto, bd audio settings to direct, audio att to on, audio drc to auto, and it is also set to 96khz/24 bit. pretty sure those should be good settings. Also when I try to set the volume settings for each speakers does not let me do it to the final two rear surround speakers. I moved some speakers around to make sure they were not the speakers, and they work fine wherever I mount them.
liljoe1969 is offline   Reply With Quote
Old 02-08-2010   #4
Administrator
 
rbinck's Avatar
 
Join Date: Mar 2009
Location: Katy, TX
Posts: 768
Default Re: 7.1 surround not working

It sounds like the settings are fine, so I don't have anything more to suggest.
rbinck is offline   Reply With Quote
Old 02-10-2010   #5
Member
 
Join Date: Feb 2008
Location: South east Florida
Posts: 25
Default Re: 7.1 surround not working

I can't help with Sony-specific issues, however here are some things to verify that you've already done:

Is there a Zone 2 setting that is redirecting 2 channels elsewhere?

Ensure the material you're playing is actually emitting 5.1 and 7.1 sound - a lot of material isn't 5.1 and very little is truly 7.1

Channel-indicator-lights may be not working - swap a few "known" working channels to all 7 speaker connections - prove that the wiring to all 7 speakers has no issues

If it's an integrated receiver skip thes next step and go to the end:

If it is an SSP and you have separate amps, repeat speaker verification process with amp channels - prove that each channel is working properly by taking a "known" working input and getting sound through to each of the 7 speaker/amp channels
Also prove your interconnects are working - take them out of the trouble-shooting loop by process of elimination - testing each on a known working speaker/amp channel

If you've done all this - you have verified that
the speaker wiring has no issues,
Interconnects / amp channels have no issues
by process of elimination you have proved that it either is a setting within the unit or (for integrated receiver) an amp/channel within the unit
Celt16 is offline   Reply With Quote
Old 03-31-2010   #6
Banned
 
Join Date: Mar 2010
Posts: 16
Default Re: 7.1 surround not working

I suggest you checked the audio settings on the BD player.
ticy is offline   Reply With Quote
Sponsored Links
Reply

Tags
71, att, audio, back, drc, hdmi, isnt, process, rear, receiver, receivers, settings, sound, speakers, surround, working

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best bookshelf surround 5.1 for under $2k kremkennegger Surround Sound 7 10-01-2008 05:17 PM
working on new HT now; couple of questions... hmmm Show us your System 1 05-31-2008 03:57 AM
Surround speakers kennyt Surround Sound 10 11-30-2007 02:32 AM
Demand working HDMI connections! TheMoose HDMI 2 10-16-2007 09:02 PM




SEO by vBSEO 3.6.1